GL1800Riders Forums banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
143 Posts
Discussion Starter · #1 ·
Radio preset buttons 4, 5 and 6 no longer work. Buttons 1, 2 and 3 do work. all other buttons work fine. I've had the radio apart hoping to find a blown fuse, but didn't see anything. Anyone got any ideas on what could be wrong? Did I miss a fuse when I took the radio apart?

This is for a 2002 model.

Thanks.
 

·
Registered
Joined
·
20,014 Posts
No, there is no fuse in the radio, but a fuse won't cause that kind of problem. The problem is a bad keyboard. I do GL1800 radio repairs. If you are interested in getting it fixed, send me a PM.

You can also try taking the keyboard apart to see if it is just dirt binding up the keys. Take out the 4 black screws that hold the bezel down and pull the whole keyboard off. There are about 8 small screws holding the circuit board down. The whole thing comes apart in layers. It is not to hard, but you have to pay attention to the order you took everything apart.

That will fix many keyboard issues. But once in awhile there is actually an electrical problem with the keyboard.
 

·
Registered
Joined
·
1,064 Posts
Radio

Before you go any further, disconnect the battery for just a moment and hook back up. Had this happen before and this took care of the problem.
 

·
Registered
Joined
·
143 Posts
Discussion Starter · #4 ·
No, there is no fuse in the radio, but a fuse won't cause that kind of problem. The problem is a bad keyboard. I do GL1800 radio repairs. If you are interested in getting it fixed, send me a PM.

You can also try taking the keyboard apart to see if it is just dirt binding up the keys. Take out the 4 black screws that hold the bezel down and pull the whole keyboard off. There are about 8 small screws holding the circuit board down. The whole thing comes apart in layers. It is not to hard, but you have to pay attention to the order you took everything apart.

That will fix many keyboard issues. But once in awhile there is actually an electrical problem with the keyboard.
Before you go any further, disconnect the battery for just a moment and hook back up. Had this happen before and this took care of the problem.
Thanks for the suggestions. I've actually had the radio pulled apart, cleaned it out, cleaned the contacts, etc. Still no go. I've also used a jumper wire to jump across the contacts on the board, but that didn't work either. So, if there's no hidden fuse, or something, easily replaceable in the radio, then I guess I'll live with only 3 presets.
 
1 - 4 of 4 Posts
Top