GL1800Riders Forums banner
1 - 5 of 5 Posts

· Registered
Joined
·
242 Posts
Discussion Starter · #1 ·
Just finished a cb and antenna install and was checking out how everything worked. I push the mute button (the one and only time i pushed it since i bought the bike new) and it is stuck in the "mute" position. Any suggestions on how to un-stick it would be appreciated.

Thanks,

Bill
02 Pearl Orange Abs
 
G

·
Mine stuck once. I "flicked" it a few times on one corner or the other and it came loose. Since then I have cleaned it and had no other trouble.
 

· Smoky
Joined
·
1,190 Posts
Just finished a cb and antenna install and was checking out how everything worked. I push the mute button (the one and only time i pushed it since i bought the bike new) and it is stuck in the "mute" position. Any suggestions on how to un-stick it would be appreciated.

Thanks,

Bill
02 Pearl Orange Abs
Buy some electrical contact cleaner. Spray it around the switch and play with it a little and it will free up and work again. Well, at least mine always has.
 

· Registered
Joined
·
242 Posts
Discussion Starter · #4 ·
Frosty Wing,

thanks,
the contact cleaner did the trick. I was worried i was looking at having to replace the whole unit... i say this because my cruise button was sticking awhile back and the dealer said they can't be repaired and replaced the right side contol pod under warranty. Probably would cost a bundle to replace it.

Bill
02 Pearl Orange Abs
 

· Smoky
Joined
·
1,190 Posts
Frosty Wing,

thanks,
the contact cleaner did the trick. I was worried i was looking at having to replace the whole unit... i say this because my cruise button was sticking awhile back and the dealer said they can't be repaired and replaced the right side contol pod under warranty. Probably would cost a bundle to replace it.

Bill
02 Pearl Orange Abs
No problem, glad I could help as other on this board have helped me :biggrin:! You can use it on all the switches. If you do have to take the switch apart to clean and free up, Fred H has a lot of fixes on his site at http://www.pbase.com/fredharmon . Mine only seem to give me trouble when it gets real cold out but I think most of that problem is the grease gets real thick and hangs it up.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top