GL1800Riders Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My 2002 GL1800 has developed an on again-off again turn signal problem. Both left and right turn signal are effected. The hazard blinker is fine, stop light is good. If the blinkers are working, I hit a bump in the road and they don't work...hit a bump and SOMETIMES they come back on. I'm getting ready for a long ride, much at night and I've got to figure this one out. I don't think it's the switch. I get the feeling it goes off when the BACK tire passes over a bump.

Anybody experienced this?? Gosh, it would be great to get this fixed...with some particulars on "how to" for an electrically challenged rider.

Thanks in advance for anyone who can shed light on this.
 

·
Registered
Joined
·
24,624 Posts
Just a few things to quickly check.

Check the speed sensor connector.

Check the ground under the rubber cover on the right side.

If Ok, play with the switch, bump it , fiddle with it, make sure it works. If OK

Check the green connector in the steering head. Could be loose. Also check the connector first to the cancel unit under the steering column before going in after the green connector.

Or you can stick needles in wires and do power checks without tearing things apart.

With a manual and a schematic.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thanks kit carson!

I'm going to check those areas you mentioned. Got to fix this. Sometimes blinker will work the whole day, then it's out for hrs, then on.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I hope!

I just got that one reply from Kit Carson. I'll see if I can do. I'm putting an ac in the bedroom today too...no more cooling off the entire empty house just for me and Millie.

THANKS
 

·
Registered
Joined
·
1,084 Posts
turn signals

I damaged the wire(s) going into the turn

cancel switch and the turn signals stopped

working while we were on a overnite ride.

Almost $500.00 to get repaired by a Honda

dealer. :oops: A small piece of tape would have

fixed the short. This was my first and last

visit to a dealer for repairs. :oops:
 

·
Registered
Joined
·
20,983 Posts
I damaged the wire(s) going into the turn

cancel switch and the turn signals stopped

working while we were on a overnite ride.

Almost $500.00 to get repaired by a Honda

dealer. :oops: A small piece of tape would have

fixed the short. This was my first and last

visit to a dealer for repairs. :oops:
how did u damage the wires ?

i will guess u somehow pinched them when installing the little cover under the left handlebar ?
 

·
Registered
Joined
·
1,084 Posts
damage

The pinched wire under the cover was a year

or so later.

I damaged the wire(s) as they go onto

the hollow stem (shaft). :oops: :oops: :oops: While

torqueing the stem bearings. Fred's DVDs

would have prevented this and other mistakes.

"You dont know what you dont know!"



 

·
Registered
Joined
·
1,630 Posts
I had the same problem a few years back. I called the dealer and they said it sounded unusual for that to go bad. said thay had never sold one and the tech said he did not think that was it. He said to look behind meter panel something unplugged. Well, tore it down and stick out like a sore thumb was the connector, unplugged.
Had never been fully plugged together for the lock tab to lock.

Dealer was Honda of Van Wert, Van Wert OH
 
1 - 9 of 9 Posts
Top