GL1800Riders Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
419 Posts
Discussion Starter #1
The gauge at my house said it was 2 degrees this morning for my ride in. I'm not exactly sure what a temperature "degree" looks like, so I kept looking for the pair of them all the way into work this morning. I couldn't find them anywhere, so I hope they're off making babies somewhere and will multiply rapidly in the near future.

The other possibility is that my gauge is wrong and there weren't actually any of those little buggers out there. The radio said there were 0 of them running around the downtown area and the Miller sign said there were -2 of them out towards my house. I can understand how they might all decide to leave for vacation at the same time and head down south leaving nobody to keep us northern folks company, I'm just not sure how there can be less than zero of them. Must be a misprint of some kind.
 

·
Fire Eating Member
Joined
·
6,473 Posts
It was 47 degrees here in the deep south this morning... BRRRR ...
would whom ever left the door open.. PLEASE CLOSE IT !!

I hate cold... thats why I live in the south....

cosmic
 

·
Registered
Joined
·
419 Posts
Discussion Starter #4
Rob(in S.C.) said:
I take it the "ride in" was in your car??
Now what kind of fun would that be..... :D

I've only got a half hour commute, so it wasn't too bad on the bike. The Gerbing liner and gloves I bought this year definitely help. I do need to find some riding pants as the chaps just aren't enough when it gets below about 20.

The traffic was flowing pretty good today, so we actually hit 80mph for a bit. One of these days I will have to see if there are any windchill charts that show below zero temps at 80mph.

WCCO claims we are all the way up to 5 degrees. If it keeps going, I may not even have to go out at lunch to warm up the bike.
 

·
Registered
Joined
·
1,095 Posts

·
Registered
Joined
·
165 Posts
Well, it was subzero something around -14 I think when I left work this morning. Didnt realize the temp display on the wing doesnt register below zero. Its an 85 mile ride for me, and the temp was up to 14 on the guage by the time I got to the shop. It started leaking oil, am waiting to hear back from them to see what they found.
The only problem I am having in the cold is with the fingers and toes. I think I will get a pair of heated socks and a set of them Hippo Hands from Santa, hopefully that will help. Other than that, the Arctic level Carharts are doing fine.
Todd
 
1 - 6 of 6 Posts
Top