GL1800Riders Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
584 Posts
Discussion Starter · #1 ·
I have a whine when Intercom is on, I know it has to do with my Garmin 665 its been doing it since installed last year but seems to have gotten louder lately,

what are some of you using as a noise inline filter for gps's that your having good success with?

I use to run it all through the Kennedy setup so i could bluetooth my phone but got rid of all that a while back and went with the J&M setup for the wing.

I dont hear the whine while using the bluetooth helmets only when i have to plug in the regular headsets.

Thanks
 

·
Registered
Joined
·
1,291 Posts
You probably need a ground loop isolator. If you power the GPS from the bike, and run the audio back through the bikes sound system, it produces a ground loop, and that gives you the whine. I also noticed that even with a GLI, I still got some whine. I used the other EC filters, and while they didn't get rid of it, they reduced it a lot.


http://electricalconnection.com/audio/filter-gli.htm
http://electricalconnection.com/audio/filter-power.htm

Try these, they should help some.


<edit> The Kennedy stuff most likely had a GLI in it. (a lot of their stuff does)
=Dave=
 

·
Registered
Joined
·
8,475 Posts
Whine through Intercom ??? :eek:4: I normally use a glass, but hey, whatever works for you. :lol:

Sorry, couldn't resist.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top