GL1800Riders Forums banner
  • Hey everyone! Enter your ride HERE to be a part of MAY's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
1,127 Posts
Discussion Starter · #1 ·
Brought the Black Beauty home from the dealer today. I sure was glad to see it again. They had it for two weeks, initial estimate was 4 days. :(

Frame weld looks OK from a quick visual. Will jack it up and check it closely later.

Definitely noticed the smoother throttle response in first gear with the new ECM. Temp gauge runs a tick or two lower than it did. The left cylinder head had to be replaced because it flunked the volume test. Seems to be OK.

All the repair work looks OK at this point. No they didn't wash it. It is still as dirty as it was when I dropped it off. No charges for any of it!
:D
They did not fix the problem though, it still took 140 (s)miles to make the 26 mile trek home from the dealer. :lol:

Maybe a new Garmin 2610 would fix it??? :D Not sure I want it fixed though.
 

·
Registered
Joined
·
5,258 Posts
to fix that problem you need to walk backwards around the bike 5 times while waving your hands in the air...

make sure there are pictures taken
 

·
Registered
Joined
·
12,417 Posts
Good news Fuzzster.

All I can tell you, is that the 2610 only complicates the problem and causes your machine to burn even more fuel!

Only thing that might stop the incessant miles is a jealous, mean wife...LOL

Bulldog
 

·
Registered
Joined
·
2,628 Posts
What Tony said, only to really work, you have to publish the pix here. :lol:
 

·
Registered
Joined
·
188 Posts
and once you get the picture posted here and after everything else has been all said and done we will be able to completely come up with a cure...trust us he he he :lol: if not we will contact Dr. Phil for you :roll:
 
1 - 6 of 6 Posts
Top