GL1800Riders Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
183 Posts
Discussion Starter #1
I fired up my 665 today, set the XM player and took a ride. To do that you have to press the wrench icon (tools). When the audio icon appeared I pressed it, as usual to get the XM started. I went back to tools and was trying to turn on my weather as well. The weather icon is gone. Nowhere to be found. I reloaded the new updates to see if that would correct it and bring it back. No such luck. Has anyone else had this experience? Any ideas on were the weather icon went?

I am baffled...

Shnev
 

·
Registered
Joined
·
1,939 Posts
Sometimes the weather icon can take up to 10-15 min before it appears, this is normal operation.
 

·
Registered
Joined
·
361 Posts
If you don't get XM or TRAFFIC either, the problem is the antenna. I had that happen when the antenna wire became crimped.
 

·
Registered
Joined
·
183 Posts
Discussion Starter #5
XM renewed my annual service. The renewal was for $124. That leads me to believe that they turned off my weather service when they did the auto renew. I turned on the XM last night and went to the service activation page on the Zumo. I shows the tier of music I receive and says that there is no data activation. So, although I got a great education over at the Zumo Forum, I think that all I will need to do is call (when I'm ready) and have the XM Weather restarted.

When I called XM Customer Care over the weekend, it was difficult to get anything done with the rep I was talking to. I did manage to get my address and email updated, without a hitch.

Thanks for all of the replies.
 

·
Registered
Joined
·
109 Posts
665 is an awesome GPS....when it works. Mine did the exact thing among other issues. I got tired of messing with it and xm customer service is horrible.....so I sold it. Good luck.
 
1 - 6 of 6 Posts
Top